Router VyOS para laboratorios Hyper-V

22 diciembre 2015
Josep Ma Solanes 4

A menudo, los laboratorios, entornos de pruebas de concepto o de estudio requieren disponer de redes separadas con un elemento que las interconecte. Es decir, poder tener un enrutador o router (en inglés) para jugar con el tránsito de red. No todos los entornos virtuales, a fecha de hoy, disponen de estos elementos que nos permitan configurar hasta el más mínimo detalle simulando un core o cortafuegos, por lo que normalmente se recurre a sistemas operativos para hacer algunas de estas cositas, con la desventaja que seguramente en el entorno real no se configuran de esta forma.

En este aspecto, un hallazgo que hace tiempo hice fué Vyatta que fué adquirida por Brocade. Pero la comunidad Opensource no se quedó de brazos cruzados sacando una versión a partir de Vyatta llamada VyOs. Un sistema operativo enfocado a las funciones de red, libre basado en Linux, que proporciona capacidades de enrutamiento, cortafuegos y VPN. Para hacer un símil es como disponer de un router Hewlett Packard o Cisco. Con una línea de comandos muy parecida a los dispositivos de red electrónicos y un consumo de recursos más ligero que los sistemas operativos completos, muy de agradecer cuando se montan laboratorios con un montón de máquinas virtuales donde precisamente no sobre absolutamente nada.

Podéis encontrar el proyecto en la web http://www.vyos.net. Donde encontraréis la versión para descargar, manuales y la comunidad.

Pero el objetivo de esta entrada no es hablar de VyOS, que sí, si no más bien poder montar un entorno de red de laboratorio con su red pública, la desmilitarizada y la interna que tan a menudo encontramos en nuestras instalaciones. Por eso utilizo una máquina virtual sobre el entorno Microsoft Hyper-V para controlar el tránsito entre las redes.

Para entender el concepto de las redes separadas y funcionamiento de un router/cortafuegos que se coloque en la red, seguiré el siguiente esquema de configuración de un pequeño laboratorio, donde se simulan estas redes y un servicio Web publicado en la DMZ.

 

Diagrama del laboratori de xarxes amb VyOS

El objetivo final del laboratorio es:

  • El equipo cliente de la red interna tiene que acceder al servidor ubicado en la DMZ, sólo al servicio Web y al Escritorio remoto.
  • El equipo cliente de la red interna tiene que poder navegar por Internet.
  • El equipo cliente de la red pública tiene que acceder al servicio Web que ofrece el servidor ubicado en la DMZ.
  • No tiene que haber más comunicación entre las redes que ésta.

Empecemos. La imagen de instalación de VyOs se puede obtener desde su web principal en la dirección: http://mirror.vyos.net/iso/release. Hacer clic sobre la carpeta de la versión que queráis, normalmente la última, en este caso, la 1.1.6.

laboratori-xarxes-vyos-01

Del listado de archivos hacer clic sobre el archivo .ISO de la versión que corresponda. La de 64 bits (amd64) es la recomendada y ya incluye los controladores y herramientas para los hipervisores Microsoft Hyper-V, Wmware, Citrix XenServer y KVM.
laboratori-xarxes-vyos-02

Creación máquina virtual VyOS con Hyper-V

Desde el Administrador de Hyper-V, en la parte derecha de acciones,  hacer clic en Nuevo, del menú desplegable hacer clic en Nueva máquina virtual.

laboratori-xarxes-vyos-03

En el asistente de creación de una máquina virtual se especifica el nombre y donde se tiene que almacenar la máquina virtual. Hacer clic en el botón Siguiente para continuar.

laboratori-xarxes-vyos-004

Como que es una máquina Linux, la compatibilidad con la Generación 2 del hipervisor no está soportada. Por lo tanto, seleccionar Generación 1 y hacer clic en el botón Siguiente.

laboratori-xarxes-vyos-005

Indicar la cantidad de memoria RAM al valor recomendado de 512 MB sin utilizar memoria dinámica, desmarcar el checkbox. Hacer clic en el botón Siguiente para continuar.

laboratori-xarxes-vyos-006

Seleccionar crear un disco virtual. Indicar el nombre del disco, la ubicación y el tamaño de 2 GB. Hacer clic en el botón Siguiente para continuar.

laboratori-xarxes-vyos-007

Seleccionar instalar el sistema operativo más tarde, de momento sólo creamos la máquina. Hacer clic en el botón Siguiente.

laboratori-xarxes-vyos-008

Resumen de la configuración de la máquina virtual. Hacer clic en el botón Finalizar.

laboratori-xarxes-vyos-009

Acabamos de perfilar la configuración de la nueva máquina virtual que actúa como router VyOS. Botón derecho sobre la máquina virtual y hacer clic en Configuración.

laboratori-xarxes-vyos-010

En la opción BIOS, asegurar que se inicia en primer lugar desde CD y después desde el disco duro IDE.

laboratori-xarxes-vyos-011

En IDE Controller 1, DVD Drive, cargar la imagen de instalación de VyOS. Seleccionar archivo de imagen y indicar el nombre del archivo .ISO que se ha descargado previamente.

laboratori-xarxes-vyos-012

Por defecto sólo se dispone de una tarjeta de red.

laboratori-xarxes-vyos-013

Para la configuración que se tiene que montar se necesitan tres patas (tres tarjetas). Por lo tanto, hacer clic en Añadir nuevo hardware. Seleccionar Tarjeta de red y hacer clic en el botón Añadir. Repetir la operación una vez más para disponer de tres tarjetas.

laboratori-xarxes-vyos-014

Las tarjetas, ahora mismo, no están conectadas a ninguna red. Hay que seleccionar el conmutador virtual que corresponda según vuestra configuración en cada tarjeta. En mi caso:

  • 1a tarjeta (eth0) – Red pública
  • 2a tarjeta (eth1) – Red interna
  • 3a tarjeta (eth2) – Red DMZ

Hacer clic en el botón Ok cuando todo esté correcto para hacer las modificaciones en la máquina virtual.

Si se crean las redes virtuales para un entorno aislado, recordad que en el conmutador virtual tenéis que seleccionar el tipo de conmutador de red Privada.

Iniciar la nueva máquina virtual para instalar el VyOS. Botón derecho sobre la máquina virtual y del menú hacer clic en Conectar para abrir la consola.

laboratori-xarxes-vyos-017

Ya en la consola, en la barra de botones, hacer clic en arrancar y con el ratón hacer clic de nuevo en la pantalla negra para pasarle el foco (las acciones) del teclado a la consola de la máquina virtual.

laboratori-xarxes-vyos-018

Recordar que para salir de la consola de la máquina virtual con Hyper-V tenéis que pulsar la combinación de teclas Control + ALT + flecha del cursor hacía la izquierda.

laboratori-xarxes-vyos-021

Se inicia la máquina virtual arrancando el sistema operativo VyOS desde la imagen ISO. Lo primero que sale es un menú donde se indica el nombre de usuario (vyos), la contraseña (vyos) y el comando para hacer la instalación del VyOS en el disco duro. Al cabo de unos segundos continúa la carga del sistema.

laboratori-xarxes-vyos-019

Cuando termina la carga del sistema se queda pidiendo el login. Escribir: vyos con la contraseña: vyos. Sistema arrancado, aparece el prompt de consulta: vyos@vyos:~$

laboratori-xarxes-vyos-020

Realizamos la instalación del sistema operativo, escribir el comando:

install image

Se inicia el asistente de instalación con toda una serie de preguntas:

Would you like to continue? [Yes]: Pulsar la tecla INTRO para continuar.
Partition (Auto/Parted/Skip) [Auto]: Se puede dejar en automático, pulsar la tecla INTRO para continuar.

Enseña el disco duro que tiene la máquina virtual, normalmente sda de 2 GB (2147MB).

Install the image on? [sda]: Pulsar la tecla INTRO para validar este disco.
Advertencia que se destruirá todo el contenido del disco duro. Se tiene que escribir la palabra Yes para poder continuar y formatear el disco duro.

Indicar el tamaño de la partición raíz a crear, por defecto todo el disco duro.
How big of a root partition should I create?[2147]: Pulsar la tecla INTRO para continuar.

Se crea la partición y el sistema de archivos y se nos pide  por el nombre de la imagen. Por defecto la versión de la ISO.
What would you like to name this image? [1.1.6]: Pulsar la tecla INTRO para continuar.

Se realiza el proceso de copia del sistema operativo y se establece el archivo de configuración del arranque:
Which one shoud I copy to sda? [/config/config.boot]: Pulsar la tecla INTRO para continuar.

Establecer la contraseña para el usuario vyos. ¡Alerta que os acordéis después de ella!.

Establecer la partición de arranque:
Which drive should GRUB modify the boot partition on? [sda]: Pulsar la tecla INTRO para continuar.

¡Proceso de instalación acabado!

laboratori-xarxes-vyos-022

Retirar la imagen ISO de la configuración de la máquina virtual (Archivo > Configuración > IDE Controller 1 > Unidad DVD. Seleccionar Ninguno y hacer clic en el botón OK.

laboratori-xarxes-vyos-023

Reiniciar la máquina virtual para arrancar ya desde el propio disco duro. Botón verde de reinicio de la barra de botones o, desde la consola VyOS escribir:

reboot now

Cuando arranca la máquina virtual vuelve a pedir el login. Recordad, escribir vyos y después la contraseña, la que habéis definido en el proceso de instalación. Si todo está correcto nos dejará en el prompt de monitor del sistema operativo VyOS.

laboratori-xarxes-vyos-024

 

Configuración de VyOS

Arrancado el sistema operativo nos encontramos en el prompt de monitorización, para configurar el dispositivo tenemos que cambiar al prompt de configuración. Escribir el siguiente comando para pasar al modo de configuración:

configure

En la consola de la máquina virtual, el idioma del teclado es el INGLÉS. Tened cuidado al escribir los comandos.

El prompt cambia de vyos@vyos:~$ a vyos@vyos# al igual como haría un router Hewlett Packard o Cisco.

laboratori-xarxes-vyos-026

Comandos básicos para operar en el router VyOS

  • show y cualquier cosa, muestra su configuración. ¿Podéis utilizar el símbolo? Para visualizar los comandos disponibles según el contexto.
  • set Establece la configuración. Si cogéis el archivo de configuración del final, para establecer las instrucciones de configuración, sólo hay que escribir set seguido de los comandos que aparecen.
  • delete Lo mismo que para set, pero esta vez borra la instrucción.
  • commit Aplica la configuración en el router, la habilita, la pone en funcionamiento en caliente. ¡Pero NO la guarda! Si se reinicia el router, ¡las modificaciones no guardadas se pierden!
  • save Guarda la configuración en el disco duro, así si se reinicia se recupera tal cual.

 

Configuración tarjetas de red del VyOS

Para establecer las direcciones IP de las tres tarjetas de red (tres patas), primero mejor confirmar que tenemos las tres tarjetas con el comando:

show interfaces

En el listado aparecen las tres tarjetas (eth0, eth1, eth2) con sus MACs correspondientes. Es un buen momento para comprobar en el hipervisor si hemos enlazado correctamente las tarjetas con el conmutador virtual que le corresponde. Archivo > Configuración > Tarjeta de red > Características avanzadas > MAC Address.

laboratori-xarxes-vyos-025

En el ejemplo propuesto, confirmo que tengo:

  • Eth0  en la red pública
  • Eth1 en la red interna
  • Eth2 en la red DMZ

Como en toda configuración de red es muy importante saber donde estamoscomo salimos, ya que un error de conexión de cable nos puede hacer bailar mucho la cabeza sin encontrar explicación.

Asignamos la configuración IP a las diferentes tarjetas de red, escribimos los siguientes comandos para fijar la IP y la descripción:

Para la red pública: 192.168.0.101/24.

set interfaces ethernet eth0 address 192.168.0.101/24
set interfaces ethernet eth0 description Red_PUBLICA

Para la red interna: 192.168.4.1/24

set interfaces ethernet eth1 address 192.168.4.1/24
set interfaces ethernet eth0 description Red_INTERNA

Para la red DMZ: 192.168.6.1/24

set interfaces ethernet eth2 address 192.168.6.1/24
set interfaces ethernet eth0 description Red_DMZ

Los cambios no se aplican automáticamente, ni se graban, pero si comprobamos la configuración de red:

show interfaces

Observamos el símbolo + delante de las líneas que se acaban de añadir a la configuración guardada. Para aplicar los cambios escribir el comando (importante que lo recordéis):

commit

Para guardar los cambios para el próximo inicio de la máquina (si no se guardan, aunque la configuración está en ejecución, cuando se reinicia el sistema operativo se pierden). Pensad en GUARDAR las configuraciones valiosas para vosotros:

save

Con las IPs configuradas en las diferentes tarjetas de red, se puede comprobar que contestan mediante los equipos ubicados en cada red haciendo un PING.

  • Desde la red pública, ping 192.168.0.101
  • Desde la red interna, ping 192.168.4.1
  • Desde la red DMZ, ping 192.168.6.1

Si todo está correcto tienen que contestar todas las IPs en cada segmento. Es más, si se pone la puerta de enlace contra el router VyOS, éste por defecto tiene habilitado el enrutamiento, de esta forma ya se puede saltar de una red a otra. Me explico, desde la red DMZ se puede hacer ping en la IP de la red pública y de la red interna del router.

laboratori-xarxes-vyos-027a

Como que no siempre es agradable trabajar desde la consola del servidor, se puede habilitar el puerto SSH para la conexión remota. Por motivos de seguridad, y es recomendable, se puede cambiar el puerto por defecto donde escucha del 22 al que queramos:

set service ssh port 22

¡Recordad de ejecutar el COMMIT y/o SAVE para aplicar y guardar los cambios!

Desde un equipo cliente se puede acceder por SSH a los comandos del router:

laboratori-xarxes-vyos-027b

 

 

Para visualizar la configuración del router, desde el prompt de monitorización (vyos@vyos:~$), escribir:

show configuration

A estas alturas poca cosa tenemos configurada más allá de las direcciones IPs de las tres tarjetas de red y el protocolo de enrutamiento habilitado. Vamos a ajustar la configuración general del router.

laboratori-xarxes-vyos-027

Configuración del servidor de DNS para resolución de nombres desde el propio router y así poder hacer las actualizaciones del sistema operativo, por ejemplo utilizando el DNS de Google (8.8.8.8):

set system name-server 8.8.8.8

El enrutamiento entre redes está hecho, pero no es lo que encontraremos en un router hacía Internet. Se trata «de esconder» las direcciones IP de la red interna sin que sean accesibles desde Internet y utilizar la IP pública para identificar todas las conexiones. Tenemos que enmascarar la red interna y la DMZ y esto se hace creando dos reglas de origen en el NAT:

Para la Red interna:

set nat source rule 100 outbound-interface eth1
set nat source rule 100 source address 192.168.4.0/24
set nat source rule 100 translation address masquerade

Para la Red DMZ:

set nat source rule 200 outbound-interface eth1
set nat source rule 200 source address 192.168.6.0/24
set nat source rule 200 translation address masquerade

¡Recordar de enviar los cambios y guardarlos: COMMIT y SAVE!

Habilitar el cortafuegos en el VyOS

Es el turno de levantar el cortafuegos en el router para evitar que el tránsito pase de un lado a otro de las redes sin control. Empezamos por la red pública que es la más expuesta. Tener claro de donde viene el tránsito, red pública (normalmente todas las redes que se identifica por la palabra «any» o la red 0.0.0.0/0), y a donde va, la tarjeta de red eth0 del router.

Crear la regla en el cortafuegos bloqueando todo el tránsito exceptuando el que se ha iniciado desde dentro hacía fuera:

set firewall name PUBLICA-INTERNA default-action 'drop'
set firewall name PUBLICA-INTERNA rule 10 action 'accept'
set firewall name PUBLICA-INTERNA rule 10 state established 'enable'
set firewall name PUBLICA-INTERNA rule 10 state related 'enable'

La regla por si sola no hace nada, hay que asignarla a la tarjeta de red que corresponda a la red pública, la eth0:

set interfaces ethernet eth0 firewall in name 'PUBLICA-INTERNA'

No nos olvidemos de proteger el propio router, la propia tarjeta de red expuesta en la red pública. Crear una regla para evitar el acceso desde la red pública al router.

Bloquear, por defecto, todo el tránsito exceptuando el iniciado desde el propio router:

set firewall name PUBLICA-ROUTER default-action 'drop'
set firewall name PUBLICA-ROUTER rule 10 action 'accept'
set firewall name PUBLICA-ROUTER rule 10 state established 'enable'
set firewall name PUBLICA-ROUTER rule 10 state related 'enable'

Pero permitimos que conteste al PING, para las pruebas de conexión siempre va bien:

set firewall name PUBLICA-ROUTER rule 20 action 'accept'
set firewall name PUBLICA-ROUTER rule 20 icmp type-name 'echo-request'
set firewall name PUBLICA-ROUTER rule 20 protocol 'icmp'
set firewall name PUBLICA-ROUTER rule 20 state new 'enable'

Permitir el acceso al puerto definido para SSH, el 22 por defecto, pero bloquearlo si me paso de conexiones:

set firewall name PUBLICA-ROUTER rule 30 action 'drop'
set firewall name PUBLICA-ROUTER rule 30 destination port '22'
set firewall name PUBLICA-ROUTER rule 30 protocol 'tcp'
set firewall name PUBLICA-ROUTER rule 30 recent count '4'
set firewall name PUBLICA-ROUTER rule 30 recent time '60'
set firewall name PUBLICA-ROUTER rule 30 state new 'enable'
set firewall name PUBLICA-ROUTER rule 31 action 'accept'
set firewall name PUBLICA-ROUTER rule 31 destination port '22'
set firewall name PUBLICA-ROUTER rule 31 protocol 'tcp'
set firewall name PUBLICA-ROUTER rule 31 state new 'enable'

Asociar la regla a la tarjeta de red pública, pero en el entorno local de la tarjeta:

set interfaces ethernet eth0 firewall local name 'PUBLICA-ROUTER'

Aplicando esta configuración, desde el equipo de la red externa ya no se puede acceder a los equipos de la red interna (192.168.4.2) ni a los de la DMZ (192.168.6.2). Si que contestan todas las tarjetas del router  (192.168.4.1 y 192.168.6.1), porque permitimos el tránsito entre ellas, sin embargo, en un dispositivo físco como cortafuegos ¡no permitiría este saltol Hemos cortado el tránsito con el cortafuegos del router VyOS.

laboratori-xarxes-vyos-028

Desde el equipo de la red interna se puede acceder al equipo de la red pública (es como navegar por Internet) y en el equipo ubicado en la red DMZ, porque aún no hemos cortado este tránsito.

Vamos a limitar las peticiones HTTP (puerto 80) desde la red pública al servidor de la DMZ (192.168.6.2):

set firewall name PUBLICA-INTERNA rule 20 action 'accept'
set firewall name PUBLICA-INTERNA rule 20 destination port 80
set firewall name PUBLICA-INTERNA rule 20 destination address 192.168.6.2
set firewall name PUBLICA-INTERNA rule 20 protocol 'tcp'
set firewall name PUBLICA-INTERNA rule 20 state new 'enable'

Pero alerta, que sólo hemos dado el permiso para acceder a nivel de router y desde la red pública el tránsito no puede entrar en la red DMZ. Los equipos de la red pública tienen que hacer la petición a la tarjeta de red del router ubicada en la red pública (192.168.0.101) en lugar de la dirección interna del servidor, que en un entorno público nunca sabremos. El router tiene que coger este tránsito y pasarlo al servidor de la red DMZ. Esta operación se hace mediante un NAT y sí, está limitada a los puertos de la dirección IP. Si se quiere publicar más de un servicio que escucha por el mismo puerto ubicado en servidores diferentes o se utilizan dos IPs públicas o se requiere de un servidor proxy inverso:

set nat destination rule 10 destination port 80
set nat destination rule 10 inbound-interface eth0
set nat destination rule 10 protocol tcp
set nat destination rule 10 translation address 192.168.6.2

Desde el equipo cliente ubicado en la red pública se accede con un navegador web a la IP del router ubicado en la red pública (192.168.0.101) y voilá, aparece la página web del servidor de la DMZ (192.168.6.2).

laboratori-xarxes-vyos-029

 

Cerrar la configuración de la red DMZ contra la red interna y al revés. Empezamos por crear una regla que cierre todo el tránsito desde la DMZ a la red interna:

set firewall name DMZ-INTERNA default-action 'drop'
set firewall name DMZ-INTERNA rule 10 action 'accept'
set firewall name DMZ-INTERNA rule 10 state established 'enable'
set firewall name DMZ-INTERNA rule 10 state related 'enable'

Y se asocia a la tarjeta de red del router ubicada en la red DMZ:

set interfaces ethernet eth2 firewall in name 'DMZ-INTERNA'

Es el turno del tránsito que va de la red intena a cualquier lugar. A diferencia de la regla pública ésta por defecto tiene que permitir el tránsito ya que no puedo controlar todas las direcciones de Internet, pero si que conozco las propias que es donde actuaré.

Se crean dos reglas para poder acceder al servicio web http (puerto 80 – regla 20) y el escritorio remoto (puerto 3389 – regla 30) y una regla específica de bloqueo (regla 99) en toda la red DMZ.

set firewall name INTERNA-DMZPUBLICA default-action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 10 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 10 state established 'enable'
set firewall name INTERNA-DMZPUBLICA rule 10 state related 'enable'
set firewall name INTERNA-DMZPUBLICA rule 20 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 20 destination port 80
set firewall name INTERNA-DMZPUBLICA rule 20 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 20 protocol 'tcp'
set firewall name INTERNA-DMZPUBLICA rule 20 state new 'enable'
set firewall name INTERNA-DMZPUBLICA rule 30 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 30 destination port 3389
set firewall name INTERNA-DMZPUBLICA rule 30 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 30 protocol 'tcp'
set firewall name INTERNA-DMZPUBLICA rule 30 state new 'enable'
set firewall name INTERNA-DMZPUBLICA rule 99 action 'drop'
set firewall name INTERNA-DMZPUBLICA rule 99 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 99 state new 'enable'

La foto parece caótica, pero tiene su explicación. Nos encontramos al equipo de la red interna:

  • Tiene una conexión con navegador en el servidor web de la DMZ (192.168.6.2).
  • Tiene una conexión de escritorio remoto al servidor de la DMZ donde se puede ver que desde él no se puede acceder al equipo de la red interna ni por ping ni por SMB.
  • Tiene un intento de acceso por SMB en el servidor de la DMZ, cosa que se le deniega.
  • Tiene una conexión para SSH en el equipo Ubuntu de la red pública donde la conexión si se permite.

laboratori-xarxes-vyos-030-cat

¡Objetivo conseguido!

Habilitar el VyOS como servidor de DHCP

Una cacacterística que puede ser interesante para olvidarnos de la asignación de direcciones IPs en el entorno de laboratorio para los diferentes segmentos de red es que el router VyOs actúe como servidor de DHCP, configurando de manera automática estas asignaciones. En el ejemplo se configura el ámbito para la red DMZ, asignando las direcciones IP desde la 192.168.6.100 a la 192.168.6.150, configurando la puerta de enlace a la IP del propio router (192.168.6.1) y como servidor DNS el de Google (8.8.8.8).

set service dhcp-server disabled false
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 start 192.168.6.100 stop 192.168.6.150
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 default-router 192.168.6.1
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 dns-server 8.8.8.8

Se puede hacer la prueba con un equipo de la red DMZ que tiene que obtener esta configuración:

laboratori-xarxes-vyos-031

 

Si no se necesita más y se quiere desactivar el servicio de DHCP en el router VyOS, el comando es:

set service dhcp-server disabled true

 

Actualización de VyOS

Sólo queda saber como tener el sistema operativo del router VyOS actualizado y, realmente, es una operación muy sencilla. El único requisito es disponer de conexión a Internet con resolución de DNS y ejecutar el siguiente comando indicando la ruta http de la imagen ISO con la nueva versión:

add system image http://ftp.qb.com.au/pub/vyos/iso/release/1.1.6/vyos-1.1.6-amd64.iso

Se inicia el asistente de configuración con unas preguntas que, al igual que el proceso de instalación, se basa en ir pulsando la tecla INTRO.

 

Para terminar

Estas son las funcionalidades básicas del router VyOs, que yo utilizo para el montaje de laboratorio donde las redes son un factor clave. Naturalmente da mucho más juego, permiten configuar VLANs, VPNs, Spanning Tree, Routing. Todo un abanico de posibilidades para poner en práctica los conocimientos de red y/o montar cualquier laboratorio al respecto.

Echadle un vistazo a la guía de configuración que es muy completa: http://vyos.net/wiki/User_Guide para avanzar más allá de esta entrada.

 

Os dejo el archivo de configuración de como ha quedado el router VyOS en esta entrada, por si lo queréis revisar con calma. Podéis realizar la configuración del VyOS en el modo de configuración y añadiendo la palabra SET seguida de las instrucciones en forma de árbol (para las claves) de este archivo. Por ejemplo, para el protocolo que en el archivo se visualiza así:

protocols {
 static {
 route 0.0.0.0/0 {
 next-hop 192.168.0.1{
 }
 }
 }
}

Sólo hay un solo comando que corresponde a

set protocols static route 0.0.0.0/0 next-hop 192.168.0.1

 

Entiendo que este artículo puede ser un poco espeso, pero es necesario entender estos conceptos de dirección de tránsito.

 

¿Te ha gustado el artículo? Lo puedes compartir en las redes sociales. También puedes dejar tu opinión, comentario o sugerencia. ¡Gracias!

 

Similar Posts by The Author:

 

4 comentaris per a
“Router VyOS para laboratorios Hyper-V”

    1. Perdona mambi, he ido retrasando este comentario al no saber la respuesta exacta. En mi caso, el Vyos lo utilizo simplemente para la conexión de redes de laboratorio, no me exige nada más. El tener o no logs en tiempo real no es una necesidad en estos entornos.

      En tu caso, ¿Cual seria la finalidad de dicho log?

       
  1. Hola, te realizo una consulta, he implementado un router Vyos para un entorno de prueba sobre HyperV. El entorno se realizo para probar la migracion de un Servidor MS Exchange. Una vez configurado correctamente el Servidor, me encuentro con que no puedo descargar correos a traves del protocolo POP, desde equipos cliente . Debo habilitar alguna regla en el Router? Gracias

     
    1. Hola Fernan, depende de como hayas configurado las redes. Si lo has hecho con NAT enmascarado, debes publicar los servicios a través del NAT. Si lo has hecho por enrutamiento NAT, asegúrate que los equipos clientes saben encontrar la red donde has ubicado el servidor de Exchange. Si tienen la puerta de enlace en otro router o firewall, debes configurar en estos la red donde has puesto el Exchange para que sepan resolverlo.

      Saludos,

       

Deixar un comentari

Recorda que no es contestaran preguntes personals, només d´interés comú que ens enriqueixin a tots.
La teva adreça de correu electrònic no serà publicada. Els camps obligatoris estan indicats.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.