Encaminador VyOS per a laboratoris Hyper-V

22 Desembre 2015
Josep Ma Solanes 2

Sovint, els laboratoris, entorns de proves de concepte o d’estudi requereixen disposar de xarxes separades amb un element que les interconnecti. És a dir, poder tenir un encaminador o router (en anglès) per jugar amb el trànsit de xarxa. No tots els entorns virtuals, a data d’avui, disposen d’aquests elements que ens permetin configurar fins al més mínim detall simulant un core o tallafocs, pel que normalment es recorre a sistemes operatius per fer algunes d’aquestes cosetes, amb el desavantatge que segurament a l’entorn real no es configuren d’aquesta forma.

En aquest aspecte, una troballa que fa temps vaig fer va ser Vyatta que va ser adquirida per Brocade. Però la comunitat Opensource no es va quedar de braços plegats traient una versió a partir de Vyatta anomenada VyOS. Un sistema operatiu enfocat a les funcions de xarxa, lliure basat en Linux, que proporciona capacitats d’encaminament, tallafocs i VPN. Per fer un símil és com disposar d’un encaminador Hewlett Packard o Cisco. Amb una línia de comandes molt semblant als dispositius de xarxa electrònics i un consum de recursos més lleuger que els sistemes operatius complets, molt d’agrair quan es munten laboratoris amb un munt de màquines virtuals on precisament no sobra absolutament res.

Podeu trobar el projecte a la web http://www.vyos.net. On trobareu la versió per descarregar, manuals i la comunitat.

Però l’objectiu d’aquesta entrada no és parlar de VyOS, que sí, sinó més aviat poder muntar un entorn de xarxa de laboratori amb la seva xarxa pública, la desmilitaritzada i la interna que tant sovint trobem a les nostres instal·lacions. Per això faig servir una màquina virtual sobre l’entorn Microsoft Hyper-V per controlar el trànsit entre les xarxes.

Per entendre el concepte de les xarxes separades i funcionament d’un encaminador/tallafocs que es col·loqui a la xarxa, seguiré el següent esquema de configuració d’un petit laboratori, on es simulen aquestes xarxes i un servei Web publicat a la DMZ.

Diagrama del laboratori de xarxes amb VyOS

L’objectiu final del laboratori és:

  • L’equip client de la xarxa interna ha d’accedir al servidor ubicat a la DMZ, només al servei Web i a l’Escriptori remot.,
  • L’equip client de la xarxa interna ha de poder navegar per Internet.
  • L’equip client de la xarxa pública ha d’accedir al servei Web que ofereix el servidor ubicat a la DMZ.
  • No hi ha d’haver més comunicació entre les xarxes que aquesta.

Comencem. La imatge de instal·lació de VyOS es pot obtenir des de la seva web principal a l’adreça: http://mirror.vyos.net/iso/release. Clicar damunt la carpeta de la versió que vulgueu, normalment la última, en aquest cas, la 1.1.6.

laboratori-xarxes-vyos-01

Del llistat de fitxers clicar sobre el fitxer .ISO de la versió que correspongui. La de 64 bits (amd64) és la recomanada i ja inclou els controladors i eines pels hipervisors Microsoft Hyper-V, Vmware, Citrix XenServer i KVM.
laboratori-xarxes-vyos-02

Creació màquina virtual VyOS amb Hyper-V

Des de l’Administrador de Hyper-V, a la banda dreta d’accions, clicar a Nou, del menú desplegable clicar a Nova màquina virtual.

laboratori-xarxes-vyos-03

En l’assistent de creació d’una màquina virtual s’especifica el nom i on s’ha d’emmagatzemar la màquina virtual. Clicar el botó Següent per continuar.

laboratori-xarxes-vyos-004

Com que és una màquina Linux, la compatibilitat amb la Generació 2 de l’hipervisor no està suportada. Per tant, seleccionar Generació 1 i clicar el botó Següent.

laboratori-xarxes-vyos-005

Indicar la quantitat de memòria RAM al valor recomanat de 512 MB sense utilitzar memòria dinàmica, desmarcar el piscu. Clicar el botó Següent per continuar.

laboratori-xarxes-vyos-006

Seleccionar crear un disc virtual. Indicar el nom del disc, la ubicació i la mida de 2 GB. Clicar el botó Següent per continuar.

laboratori-xarxes-vyos-007

Seleccionar instal·lar el sistema operatiu més tard, de moment només creem la màquina. Clicar el botó Següent.

laboratori-xarxes-vyos-008

Resum de la configuració de la màquina virtual. Clicar el botó Finalitzar.

laboratori-xarxes-vyos-009

Acabem de perfilar la configuració de la nova màquina virtual que actua com a encaminador VyOS. Botó dret damunt la màquina virtual i clicar a Configuració.

laboratori-xarxes-vyos-010

A l’opció BIOS, assegurar que s’inicia en primer lloc des de CD i després des del disc dur IDE.

laboratori-xarxes-vyos-011

A IDE Controller 1, DVD Drive, carregar la imatge de instal·lació de VyOS. Seleccionar fitxer de imatge i indicar el nom del fitxer .ISO que s’ha descarregat prèviament.

laboratori-xarxes-vyos-012

Per defecte només es disposa d’una targeta de xarxa.

laboratori-xarxes-vyos-013

Per la configuració que s’ha de muntar es necessiten tres potes (tres targetes). Per tant, clicar a Afegir nou maquinari. Seleccionar Targeta de xarxa i clicar el botó Afegir. Repetir l’operació un cop més per disposar de tres targetes.

laboratori-xarxes-vyos-014

Les targetes, ara mateix, no estan connectades a cap xarxa. Cal seleccionar el commutador virtual que correspongui segons la vostra configuració a cada targeta. En el meu cas:

  • 1a targeta (eth0) – Xarxa pública
  • 2a targeta (eth1) – Xarxa interna
  • 3a targeta (eth2) – Xarxa DMZ

Clicar el botó OK quan tot sigui correcte per fer les modificacions a la màquina virtual.

Si es creen les xarxes virtuals per un entorn aïllat, recordeu que en el commutador virtual heu de seleccionar el tipus de commutador de xarxa Privada.

Iniciar la nova màquina virtual per instal·lar el VyOS. Botó dret damunt la màquina virtual i del menú clicar a Connectar per obrir la consola.

laboratori-xarxes-vyos-017

Ja a la consola, a la barra de botons, clicar a engegar i amb el ratolí clicar de nou a la pantalla negre per passar-li el focus (les accions) del teclat a la consola de la màquina virtual.

laboratori-xarxes-vyos-018

Recordar que per sortir de la consola de la màquina virtual amb Hyper-V heu de prémer la combinació de tecles Control + ALT + fletxa del cursor cap a l’esquerra.

laboratori-xarxes-vyos-021

S’inicia la màquina virtual arrancant el sistema operatiu VyOS des de la imatge ISO. El primer que surt és un menú on s’indica el nom d’usuari (vyos), la contrasenya (vyos) i la comanda per fer la instal·lació del VyOS al disc dur. Al cap d’uns segons continua la càrrega del sistema.

laboratori-xarxes-vyos-019

Quan acaba la càrrega del sistema es queda demanant el login. Escriure: vyos amb la contrasenya: vyos. Sistema arrancat, apareix el prompt de consulta: vyos@vyos:~$

laboratori-xarxes-vyos-020

Realitzem la instal·lació del sistema operatiu, escriure la comanda:

install image

S’inicia l’assistent d’instal·lació amb tota una sèrie de preguntes:

Would you like to continue? [Yes]: Prémer la tecla INTRO per continuar.
Partition (Auto/Parted/Skip) [Auto]: Es pot deixar en automàtic, prémer la tecla INTRO per continuar.

Ensenya el disc dur que té la màquina virtual, normalment sda de 2 GB (2147MB).

Install the image on? [sda]: Prémer la tecla INTRO per validar aquest disc.
Advertència que es destruirà tot el contingut del disc dur. S’ha d’escriure la paraula Yes per poder continuar i formatar el disc dur.

Indicar la mida de la partició arrel a crear, per defecte tot el disc dur.
How big of a root partition should I create?[2147]: Prémer la tecla INTRO per continuar.

Es crea la partició i el sistema de fitxers i se’ns demana pel nom de la imatge. Per defecte la versió de la ISO.
What would you like to name this image? [1.1.6]: Prémer la tecla INTRO per continuar.

Es realitza el procés de còpia del sistema operatiu i s’estableix el fitxer de configuració de l’arrancada:
Which one shoud I copy to sda? [/config/config.boot]: Prémer la tecla INTRO per continuar.

Establir la contrasenya per l’usuari vyos. Alerta que us recordeu després d’ella!.

Establir la partició d’arrancada:
Which drive should GRUB modify the boot partition on? [sda]: Prémer la tecla INTRO per continuar.

Procés de instal·lació acabat!

laboratori-xarxes-vyos-022

Retirar la imatge ISO de la configuració de la màquina virtual (Fitxer > Configuració > IDE Controller 1 > Unitat DVD. Seleccionar Cap i clicar el botó OK.

laboratori-xarxes-vyos-023

Reiniciar la màquina virtual per arrancar ja des del propi disc dur. Botó verd de reinici de la barra de botons o, des de la consola VyOS escriure:

reboot now

Quan arranca la màquina virtual torna a demanar el login. Recordeu, escriure vyos i després la contrasenya, la que heu definit en el procés de instal·lació. Si tot és correcte ens deixarà al prompt de monitor del sistema operatiu VyOS.

laboratori-xarxes-vyos-024

 

Configuració de VyOS

Arrancat el sistema operatiu ens trobem al prompt de monitoratge, per configurar el dispositiu hem de canviar al prompt de configuració. Escriure la següent comanda per passar al mode de configuració:

configure

En la consola de la màquina virtual, l’idioma del teclat és l’ANGLÈS. Aneu en compte a l’escriure les comandes.

El prompt canvia de vyos@vyos:~$ a vyos@vyos# al igual com faria un encaminador Hewlett Packard o Cisco.

laboratori-xarxes-vyos-026

Comandes bàsiques per operar en l’encaminador VyOS

  • show i qualsevol cosa, mostra la seva configuració. Podeu utilitzar el símbol ? Per visualitzar les comandes disponibles segons el context.
  • set Estableix la configuració. Si agafeu el fitxer de configuració del final, per establir les instruccions de configuració, només cal escriure set seguit de les comandes que hi apareixen.
  • delete El mateix que per set, però aquest cop esborra la instrucció.
  • commit Aplica la configuració a l’encaminador, l’habilita, la posa en funcionament en calent. Però NO la guarda! Si es reinicia l’encaminador, les modificacions no guardades es perden!
  • save Guarda la configuració al disc dur, així si es reinicia es recupera tal qual.

 

Configuració targetes de xarxa del VyOS

Per establir les adreces IP de les tres targetes de xarxa (tres potes), primer millor confirmar que tenim les tres targetes amb la comanda:

show interfaces

En el llistat apareixen les tres targetes (eth0, eth1, eth2) amb les seves MACs corresponents. És un bon moment per comprovar en l’hipervisor si hem enllaçat correctament les targetes amb el commutador virtual que li correspon. Fitxer > Configuració > Targeta de xarxa > Característiques avançades > MAC Address.

laboratori-xarxes-vyos-025

En l’exemple proposat, confirmo que tinc:

  • Eth0  a la xarxa pública
  • Eth1 a la xarxa interna
  • Eth2 a la xarxa DMZ

Com en tota configuració de xarxa és molt important saber on som i com sortim, ja què un error de connexió de cable ens pot fer ballar molt el cap sense trobar explicació.

Assignem la configuració IP a les diferents targetes de xarxa, escrivim les següents comandes per fixar la IP i la descripció:

Per la xarxa pública: 192.168.0.101/24.

set interfaces ethernet eth0 address 192.168.0.101/24
set interfaces ethernet eth0 description Xarxa_PUBLICA

Per la xarxa interna: 192.168.4.1/24

set interfaces ethernet eth1 address 192.168.4.1/24
set interfaces ethernet eth0 description Xarxa_INTERNA

Per la xarxa DMZ: 192.168.6.1/24

set interfaces ethernet eth2 address 192.168.6.1/24
set interfaces ethernet eth0 description Xarxa_DMZ

Els canvis no s’apliquen automàticament, ni es graven, però si comprovem la configuració de xarxa:

show interfaces

Observem el símbol + davant les línies que s’acaben d’afegir a la configuració guardada. Per aplicar els canvis escriure la comanda (important que ho recordeu):

commit

Per guardar els canvis pel proper inici de la màquina (si no es guarden, tot i que la configuració està en execució, quan es reinicia el sistema operatiu es perden). Penseu en GUARDAR les configuracions valuoses per vosaltres:

save

Amb les IPs configurades en les diferents targetes de xarxa, es pot comprovar que contesten mitjançant els equips ubicats en cada xarxa fent un PING.

  • Des de la xarxa pública, ping 192.168.0.101
  • Des de la xarxa interna, ping 192.168.4.1
  • Des de la xarxa DMZ, ping 192.168.6.1

Si tot és correcte han de contestar totes les IPs en cada segment. És més, si es posa la porta d’enllaç contra l’encaminador VyOS, aquest, per defecte té habilitat l’encaminament, d’aquesta forma ja es pot saltar d’una xarxa a una altra. M’explico, des de la xarxa DMZ es pot fer ping a la IP de la xarxa pública i de la xarxa interna de l’encaminador.

laboratori-xarxes-vyos-027a

Com que no sempre és agradable treballar des de la consola del servidor, es pot habilitar el port SSH per la connexió remota. Per motius de seguretat, i és recomanable, es pot canviar el port per defecte on escolta del 22 al què vulguem:

set service ssh port 22

Recordeu a executar el COMMIT i/o SAVE per aplicar i guardar els canvis!

Des d’un equip client es pot accedir per SSH a les comandes de l’encaminador:

laboratori-xarxes-vyos-027b

 

 

Per visualitzar la configuració de l’encaminador, des del prompt de monitoratge (vyos@vyos:~$), escriure:

show configuration

A aquestes alçades poca cosa tenim configurada més enllà de les adreces IPs de les tres targetes de xarxa i el protocol d’encaminament habilitat. Anem a ajustar la configuració general de l’encaminador.

laboratori-xarxes-vyos-027

Configuració del servidor de DNS per resolució de noms des del propi encaminador i així poder fer les actualitzacions del sistema operatiu, per exemple utilitzant el DNS de Google (8.8.8.8):

set system name-server 8.8.8.8

L’encaminament entre xarxes està fet, però no és el què trobarem en un encaminador cap a Internet. Es tracta “d’amagar” les adreces IP de la xarxa interna sense que siguin accessibles des d’Internet i utilitzar la IP pública per a identificar totes les connexions. Hem d’emmascarar la xarxa interna i la DMZ i això es fa creant dues regles d’origen al NAT:

Per la Xarxa interna:

set nat source rule 100 outbound-interface eth1
set nat source rule 100 source address 192.168.4.0/24
set nat source rule 100 translation address masquerade

Per la Xarxa DMZ:

set nat source rule 200 outbound-interface eth1
set nat source rule 200 source address 192.168.6.0/24
set nat source rule 200 translation address masquerade

Recordar a enviar els canvis i guardar-los: COMMIT i SAVE!

Habilitar el tallafocs en el VyOS

És el torn d’aixecar el tallafocs en l’encaminador per evitar que el trànsit passi d’una banda a l’altra de les xarxes sense control. Comencem per la xarxa pública que és la més exposada. Tenir clar d’on ve el trànsit, xarxa pública (normalment totes les xarxes que s’identifica per la paraula “any” o la xarxa 0.0.0.0/0), i a on va, la targeta de xarxa eth0 de l’encaminador.

Crear la regla en el tallafocs bloquejant tot el trànsit exceptuant el què s’ha iniciat des de dins cap a fora:

set firewall name PUBLICA-INTERNA default-action 'drop'
set firewall name PUBLICA-INTERNA rule 10 action 'accept'
set firewall name PUBLICA-INTERNA rule 10 state established 'enable'
set firewall name PUBLICA-INTERNA rule 10 state related 'enable'

La regla per si sola no fa res, cal assignar-la a la targeta de xarxa que correspongui a la xarxa pública, la eth0:

set interfaces ethernet eth0 firewall in name 'PUBLICA-INTERNA'

No ens oblidem de protegir el propi encaminador, la pròpia targeta de xarxa exposada a la xarxa pública. Crear una regla per evitar l’accés des de la xarxa pública a l’encaminador.

Bloquejar, per defecte, tot el trànsit exceptuant l’iniciat des del propi encaminador:

set firewall name PUBLICA-ROUTER default-action 'drop'
set firewall name PUBLICA-ROUTER rule 10 action 'accept'
set firewall name PUBLICA-ROUTER rule 10 state established 'enable'
set firewall name PUBLICA-ROUTER rule 10 state related 'enable'

Però permetem que contesti al PING, per les proves de connexió sempre va bé:

set firewall name PUBLICA-ROUTER rule 20 action 'accept'
set firewall name PUBLICA-ROUTER rule 20 icmp type-name 'echo-request'
set firewall name PUBLICA-ROUTER rule 20 protocol 'icmp'
set firewall name PUBLICA-ROUTER rule 20 state new 'enable'

Permetre l’accés al port definit per SSH, el 22 per defecte, però bloquejar-lo si em passo de connexions:

set firewall name PUBLICA-ROUTER rule 30 action 'drop'
set firewall name PUBLICA-ROUTER rule 30 destination port '22'
set firewall name PUBLICA-ROUTER rule 30 protocol 'tcp'
set firewall name PUBLICA-ROUTER rule 30 recent count '4'
set firewall name PUBLICA-ROUTER rule 30 recent time '60'
set firewall name PUBLICA-ROUTER rule 30 state new 'enable'
set firewall name PUBLICA-ROUTER rule 31 action 'accept'
set firewall name PUBLICA-ROUTER rule 31 destination port '22'
set firewall name PUBLICA-ROUTER rule 31 protocol 'tcp'
set firewall name PUBLICA-ROUTER rule 31 state new 'enable'

Associar la regla a la targeta de xarxa pública, però a l’entorn local de la targeta:

set interfaces ethernet eth0 firewall local name 'PUBLICA-ROUTER'

Aplicant aquesta configuració, des de l’equip de la xarxa externa ja no es pot accedir als equips de la xarxa interna (192.168.4.2) ni als de la DMZ (192.168.6.2). Sí que contesten totes les targetes de l’encaminador (192.168.4.1 i 192.168.6.1), perquè permetem el trànsit entre elles, no obstant, en un dispositiu físic com a tallafocs no permetria aquest salt. Hem tallat el trànsit amb el tallafocs de l’encaminador VyOS.

laboratori-xarxes-vyos-028

Des de l’equip de la xarxa interna es pot accedir a l’equip de la xarxa pública (és com navegar per Internet) i a l’equip ubicat a la xarxa DMZ, perquè encara no hem tallat aquest trànsit.

Anem a limitar les peticions HTTP (port 80) des de la xarxa pública al servidor de la DMZ (192.168.6.2):

set firewall name PUBLICA-INTERNA rule 20 action 'accept'
set firewall name PUBLICA-INTERNA rule 20 destination port 80
set firewall name PUBLICA-INTERNA rule 20 destination address 192.168.6.2
set firewall name PUBLICA-INTERNA rule 20 protocol 'tcp'
set firewall name PUBLICA-INTERNA rule 20 state new 'enable'

Però alerta, que només hem donat el permís per accedir a nivell d’encaminador i des de la xarxa pública el trànsit no pot entrar a la xarxa DMZ. Els equips de la xarxa pública han de fer la petició a la targeta de xarxa de l’encaminador ubicada a la xarxa pública (192.168.0.101) en comptes de l’adreça interna del servidor, que en un entorn públic mai sabrem. L’encaminador ha d’agafar aquest trànsit i passar-lo al servidor de la xarxa DMZ. Aquesta operació es fa mitjançant un NAT i sí, està limitada als ports de l’adreça IP. Si es vol publicar més d’un servei que escolta pel mateix port ubicat en servidors diferents o s’utilitzen dues IPs públiques o es requereix d’un servidor proxy invers:

set nat destination rule 10 destination port 80
set nat destination rule 10 inbound-interface eth0
set nat destination rule 10 protocol tcp
set nat destination rule 10 translation address 192.168.6.2

Des de l’equip client ubicat a la xarxa pública s’accedeix amb un navegador web a la IP de l’encaminador ubicat a la xarxa pública (192.168.0.101) i voilà, apareix la pàgina web del servidor de la DMZ (192.168.6.2).

laboratori-xarxes-vyos-029

 

Tancar la configuració de la xarxa DMZ contra la xarxa interna i al revés. Comencem per crear una regla que tanqui tot el trànsit des de la DMZ a la xarxa interna:

set firewall name DMZ-INTERNA default-action 'drop'
set firewall name DMZ-INTERNA rule 10 action 'accept'
set firewall name DMZ-INTERNA rule 10 state established 'enable'
set firewall name DMZ-INTERNA rule 10 state related 'enable'

I s’associa a la targeta de xarxa de l’encaminador ubicada a la xarxa DMZ:

set interfaces ethernet eth2 firewall in name 'DMZ-INTERNA'

És el torn del trànsit que va de la xarxa interna a qualsevol lloc. A diferència de la regla pública aquesta, per defecte ha de permetre el trànsit ja què no puc controlar totes les adreces d’Internet, però si que conec les pròpies que és on actuaré.

Es creen dues regles per poder accedir al servei web http (port 80 – regla 20) i l’escriptori remot (port 3389 – regla 30) i una regla específica de bloqueig (regla 99) a tota la xarxa DMZ.

set firewall name INTERNA-DMZPUBLICA default-action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 10 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 10 state established 'enable'
set firewall name INTERNA-DMZPUBLICA rule 10 state related 'enable'
set firewall name INTERNA-DMZPUBLICA rule 20 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 20 destination port 80
set firewall name INTERNA-DMZPUBLICA rule 20 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 20 protocol 'tcp'
set firewall name INTERNA-DMZPUBLICA rule 20 state new 'enable'
set firewall name INTERNA-DMZPUBLICA rule 30 action 'accept'
set firewall name INTERNA-DMZPUBLICA rule 30 destination port 3389
set firewall name INTERNA-DMZPUBLICA rule 30 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 30 protocol 'tcp'
set firewall name INTERNA-DMZPUBLICA rule 30 state new 'enable'
set firewall name INTERNA-DMZPUBLICA rule 99 action 'drop'
set firewall name INTERNA-DMZPUBLICA rule 99 destination address 192.168.6.2
set firewall name INTERNA-DMZPUBLICA rule 99 state new 'enable'

La foto sembla caòtica, però té la seva explicació. Ens trobem a l’equip de la xarxa interna:

  • Té una connexió amb navegador al servidor web de la DMZ (192.168.6.2).
  • Té una connexió d’escriptori remot al servidor de la DMZ on es pot veure que des d’ell no es pot accedir a l’equip de la xarxa interna ni per ping ni per SMB.
  • Té un intent d’accés per SMB al servidor de la DMZ, cosa que se li denega.
  • Té una connexió per SSH a l’equip Ubuntu de la xarxa pública on la connexió si es permet.

laboratori-xarxes-vyos-030-cat

Objectiu aconseguit!

Habilitar el VyOS com a servidor de DHCP

Una característica que pot ser interessant per oblidar-nos de l’assignació d’adreces IPs en l’entorn de laboratori pels diferents segments de xarxa és que l’encaminador VyOS actuï com a servidor de DHCP, configurant de manera automàtica aquestes assignacions. En l’exemple es configura l’àmbit per la xarxa DMZ, assignant les adreces IP des de la 192.168.6.100 a la 192.168.6.150, configurant la porta d’enllaç a la IP del propi encaminador (192.168.6.1) i com a servidor DNS el de Google (8.8.8.8).

set service dhcp-server disabled false
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 start 192.168.6.100 stop 192.168.6.150
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 default-router 192.168.6.1
set service dhcp-server shared-network-name DMZ subnet 192.168.6.0/24 dns-server 8.8.8.8

Es pot fer la prova amb un equip de la xarxa DMZ que ha d’obtenir aquesta configuració:

laboratori-xarxes-vyos-031

 

Si no es necessita més i es vol desactivar el servei de DHCP en l’encaminador VyOS, la comanda és:

set service dhcp-server disabled true

 

Actualització de VyOS

Només queda saber com tenir el sistema operatiu de l’encaminador VyOS actualitzat i, realment, és una operació molt senzilla. L’únic requisit és disposar de connexió a Internet amb resolució de DNS i executar la següent comanda indicant la ruta http de la imatge ISO amb la nova versió:

add system image http://ftp.qb.com.au/pub/vyos/iso/release/1.1.6/vyos-1.1.6-amd64.iso

S’inicia l’assistent de configuració amb unes preguntes que, a l’igual que el procés de instal·lació, es basa en anar prement la tecla INTRO.

 

Per acabar

Aquestes són les funcionalitats bàsiques de l’encaminador VyOS que jo utilitzo pel muntatge de laboratori on les xarxes són un factor clau. Naturalment dóna molt més joc, permeten configurar VLANs, VPNs, Spanning Tree, Routing. Tot un ventall de possibilitats per posar en pràctica els coneixements de xarxa i/o muntar qualsevol laboratori al respecte.

Doneu-li una ullada a la guia de configuració que és molt completa: http://vyos.net/wiki/User_Guide per avançar més enllà d’aquesta entrada.

 

Us deixo el fitxer de configuració de com ha quedat l’encaminador VyOS en aquesta entrada, per si el voleu revisar amb calma. Podeu realitzar la configuració del VyOS en el mode de configuració i afegint la paraula SET seguida de les instruccions en forma d’arbre (per les claus) d’aquest fitxer. Per exemple, pel protocol que en el fitxer es visualitza així:

protocols {
 static {
 route 0.0.0.0/0 {
 next-hop 192.168.0.1{
 }
 }
 }
}

Només hi ha una sola comanda que correspon a:

set protocols static route 0.0.0.0/0 next-hop 192.168.0.1

 

Entenc que aquest article pot ser una mica espès, però es necessari entendre aquests conceptes de direcció de trànsit.

 

T’ha agradat l’article? El pots compartir a les xarxes socials. També pots deixar la teva opinió, comentari o suggeriment. Gràcies!

Similar Posts by The Author:

 

2 comentaris per a
“Encaminador VyOS per a laboratoris Hyper-V”

    1. Perdona Duncan, se me ha pasado este comentario con todo el lío en el que estoy metido.

      En el arranque de Vyos, entrar en el menú de GRUB. Poner el cursor encima de la opción de arranque, por defecto VyOS (KVM console). Pulsar la tecla e para modificar los comandos de ejecución. Aparece la línea de comando, algo parecido a: linux/boot/1.1.7/vmlinuz boot=live ….

      Pues bien, de esta línea debes modificar el parámetro vyos-config=/opt/vyatta/etc/config.boot.default. Si no dispones de él añádelo después del console=tty0. Quedando la cosa de la singuiente forma:

      linux/boot/1.1.7/vmlinuz boot=live quiet vyatta-union=/boot/1.1.7 console=ttyS0,9600 console=tty0 vyos-config=/opt/vyatta/etc/config.boot.default

      Una vez hecho esto, pulsa las teclas Control + X para iniciar el Vyos. De esta forma arranca con la configuración por defecto, eliminado todo lo que tenias. Ojo, que tambien pone el usuario y password por defecto que te recuerdo es vyos. Puedes volver a crear la nueva configuración y guardarla; sobreescribiendo la anterior. Si no la guardas, al volver a arrancar vuelves a recupera la que tenias anteriormente, antes de hacer nada.

      Espero que te sirva. Saludos,

       

Deixar un comentari

Recorda que no es contestaran preguntes personals, només d´interés comú que ens enriqueixin a tots.
La teva adreça de correu electrònic no serà publicada. Els camps obligatoris estan indicats.

Aquest lloc utilitza Akismet per reduir el correu brossa. Aprendre com la informació del vostre comentari és processada